VeeCAD
https://veecad.com/yabb/YaBB.pl
General Category >> VeeCAD General Discussion >> Selection issue
https://veecad.com/yabb/YaBB.pl?num=1457631229

Message started by ev on Mar 10th, 2016 at 5:33pm

Title: Selection issue
Post by ev on Mar 10th, 2016 at 5:33pm
I am noticing that in the current build, when I try to select an item, sometimes an item above and to the left of what I click on gets selected. The effect is stubborn.

Anyone else seeing this? I am running Win10, 64 bit.

Title: Re: Selection issue
Post by Roger Lascelles on Mar 11th, 2016 at 4:43am
Hello Eric

I'm not seeing unusual behaviour in the latest release. The selection code has not been altered since many versions back.

If you look at the x,y readout at the bottom left of the VeeCAD window, you will notice how the numbers jump at exactly half-way between two holes. So each hole sits in the middle of a "cell" and the x,y readout shows the coordinates of that cell. When you click, VeeCAD looks for all components that overlap the cell and chooses the object with the least area. This feels like you are clicking the object that is under the mouse, but occasionally you feel you are selecting the "wrong" component. For example, you click near the bottom of a cell and a component gets selected that only overlaps the top of the cell.

Title: Re: Selection issue
Post by ev on Mar 12th, 2016 at 2:51am
Hi Roger,

I am attaching a screen clip to show what I am experiencing.

When I position the tip of the pointer where the red arrow points and click, the red box is selected, not the transistor. If I then click where the blue arrow points, the box is deselected.

If I click on the other pins of the transistor, the transistor is selected.

Also, when I click where the red arrow points, the connections are not highlighted. Clicking on the other pins of the transistor does highlight connections.


2016-03-11_204033.png (43 KB | 143 )

Title: Re: Selection issue
Post by Roger Lascelles on Mar 12th, 2016 at 11:09am
If you email me your VeeCAD file, I can respond in detail - and check whether or not VeeCAD has a problem.

Title: Re: Selection issue
Post by ev on Mar 12th, 2016 at 4:56pm
PM sent. Thanks Roger.

Title: Re: Selection issue
Post by Roger Lascelles on Mar 13th, 2016 at 12:26pm
The error only occurs if you use an outline like BOX2_1 which does not occupy the top left cell in the celled or custom outline editors - hence a problem we rarely experience. Caused by a bug introduced in July 2012. I will release a fixed version soon.

Many thanks for the report, Eric.

Title: Re: Selection issue
Post by ev on Mar 14th, 2016 at 5:51am
Thanks Roger - much appreciated.

VeeCAD » Powered by YaBB 2.5.2!
YaBB Forum Software © 2000-2020. All Rights Reserved.