Welcome, Guest. Please Login or Register
VeeCAD Stripboard Editor
   
  HomeHelpSearchLoginRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
NETLIST import problems (Read 19111 times)
Mycroft2152
YaBB Newbies
*
Offline


Your message here...

Posts: 4
NETLIST import problems
Jun 26th, 2008 at 11:18am
 
I've tried importing both a TANGO and Protel netlists generated by DIPTRACE schematic program In both cases Veecad 'burps' at the start of the component list in the netlist.

In Protel, the error message is -- invalid pin number "1 undefined" in Pin to Net assignment in line 584

In TANGO -- Missing "," in pin to net assignemt in line 83.

any suggestions to fix this?

Myc
Back to top
 

Skinny20.net (1 KB | )
 
IP Logged
 
Mycroft2152
YaBB Newbies
*
Offline


Your message here...

Posts: 4
Re: NETLIST import problems
Reply #1 - Jun 26th, 2008 at 11:18am
 
Here is the Protel netlist file:
Back to top
 
 
IP Logged
 
Roger Lascelles
Administrator
*****
Offline



Posts: 461
Clifton Springs, Australia
Re: NETLIST import problems
Reply #2 - Jun 26th, 2008 at 2:37pm
 
Helly Myc

The Skinny20protel.net file is "Protel Netlist 2.0" format, not the ordinary "Protel" format produced by most schematic editors.  If necessary I can add this format to VeeCAD, but it might be quicker if we debug your Tango netlist, because Tango is a very standard format.

If you post your Tango file I will get back to you.
Back to top
 

Roger
 
IP Logged
 
Mycroft2152
YaBB Newbies
*
Offline


Your message here...

Posts: 4
Re: NETLIST import problems
Reply #3 - Jun 26th, 2008 at 3:18pm
 
Hi Roger,

Thanks for the quick repl;y. Attached in the TANGO net list.

I've noticed that for importing component pins need to identified by numbers, not letters. For example on a diopde, the pin are identidied as A amd K, which causes problems.

Myc

Back to top
 
 
IP Logged
 
Mycroft2152
YaBB Newbies
*
Offline


Your message here...

Posts: 4
Re: NETLIST import problems
Reply #4 - Jun 26th, 2008 at 11:39pm
 
After a long afternnon working on the Veecad / Diptrace netlist problem. I found the solution in a old reference of yours, that The Protel and Tango formats were the same except for the use of a dash versus comma as a separator in the net connections.  That was true for Protel version 1.

Many pcb layout programs now will accept either the dash or the comma.

Diptrace uses the dash in the TANGO netlist output. Veecad is expecting a comma.

As you also said in an earlier reply, Diptrace produces a more complex Protel version 2 netlist which is not compatible with Veecad.

Base on your comments and looking at the formats of importable TANGO netlists, I tried the PROTEL selection in Veecad to import the DIPTRACE Tango netlist. It worked!. Success!

One last note; the requirement that pins must be identified with numbers and not letters or symbols, shuld be included in the help files under netlist. I found it later on the website.

Nice Program!

Myc
Back to top
 
 
IP Logged
 
Roger Lascelles
Administrator
*****
Offline



Posts: 461
Clifton Springs, Australia
Re: NETLIST import problems
Reply #5 - Jun 27th, 2008 at 9:40am
 
Excellent news.  You certainly took the situation in hand!

Just when I thought the Protel-Tango troubles were sorted out, we find that DipTrace has a different definition of "Tango"!  I will make a combined Protel-Tango importer which accepts either format.  For the moment, I will note in the Help file and on the website that DipTrace Tango is VeeCAD Protel.

The Pin identifiers restriction to numbers is mentioned in the help file under "Schematic Editors".  I will add a link to there from the "Nets" topic - or perhaps combine the two.
Back to top
 

Roger
 
IP Logged
 
chimimic
YaBB Newbies
*
Offline


Your message here...

Posts: 2
Re: NETLIST import problems
Reply #6 - Sep 19th, 2008 at 10:16am
 
Hi,

I'm a new user of commercial version of VeeCad, thanks for your good work.
I read help file and tutorials, and I understood limitation related to pins name / number convention Wink

I get the same error message when trying import a Tango netlist created by Labcenter Proteus software (no more success by choosing Protel format). I know this error message is related to some components pins name called "A" or "K", and that are not designed by a number.

Please, can you tell me if there is actually a workaround to allow me import Tango netlist created by Proteus ?

In advance, all my thanks.
Remy
Back to top
 
 
IP Logged
 
Roger Lascelles
Administrator
*****
Offline



Posts: 461
Clifton Springs, Australia
Re: NETLIST import problems
Reply #7 - Sep 19th, 2008 at 1:53pm
 
Hello Remy

For each part which causes this problem, you must make a new Proteus library part with numbered pins.  I suggest you make your own additional Proteus library with "fixed" components.  This is annoying, but you only need to add the parts you actually use, and you can copy them from the Proteus library then just modify the pin names.

Now your netlist will be accepted by VeeCAD.

Remy, if you have any further trouble, you are welcome to contact me - http://veecad.com/contact.html .  Send me your netlist if you like.
Back to top
 

Roger
 
IP Logged
 
chimimic
YaBB Newbies
*
Offline


Your message here...

Posts: 2
Re: NETLIST import problems
Reply #8 - Sep 19th, 2008 at 4:16pm
 
Hello Roger,

thanks a lot for your quick answer !

So, I made additionnal tests by modifying the Tango netlist file, I replaced following text :

",A" by ",1"
",K" by ",2"
",-" by ",1"
",+" by ",2"

and it works. I'll use this workaround, until limitation occur Wink

Thanks again,
Remy

Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print