Welcome, Guest. Please Login or Register
VeeCAD Stripboard Editor
   
  HomeHelpSearchLoginRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Trace net problem (Read 273 times)
Brainsparks30
YaBB Newbies
*
Offline


Your message here...

Posts: 2
Trace net problem
Apr 24th, 2018 at 9:18pm
 
Or how I have forgotten what I'm doing...

I have a Tinycad Protel netlist imported into Veecad, but none of the tracenets are showing.  Some of the parts I have made in my library, as I have done for other designs way back, which are fine.
What have I done wrong?

It's driving me nuts!
Back to top
 
 
IP Logged
 
Roger Lascelles
Administrator
*****
Offline



Posts: 434
Ocean Grove, Australia
Re: Trace net problem
Reply #1 - Apr 25th, 2018 at 2:09am
 
Hello Brainsparks30, and I think this is your first post!

Trace Net works on the netlist that you imported from your schematic. So first step is to go Netlist -> View on the VeeCAD menu:
  • The Component Pins tab should show almost all your component pins connecting to nets.
  • The Validation tab should show "No errors in netlist".
  • The Project tab should show "Board contains all components & pins required by Net".
If everything is as you expect with the netlist then you are left with problems like Trace Net button not "down".
Back to top
« Last Edit: Apr 27th, 2018 at 1:15am by Roger Lascelles »  

Roger
 
IP Logged
 
Brainsparks30
YaBB Newbies
*
Offline


Your message here...

Posts: 2
Re: Trace net problem
Reply #2 - Apr 26th, 2018 at 11:29pm
 
All the buttons are depressed as you say, and some of the netlist is working, with no errors reported.  However, some of the components are reported as surplus to requirements and appear to be extra to the netlist, while still shown in the Tinycad schematic. 

As far as I can tell, everything is genuinely connected and packages named.  I probably screwed up some where but it does not make any sense.
Back to top
 
 
IP Logged
 
Roger Lascelles
Administrator
*****
Offline



Posts: 434
Ocean Grove, Australia
Re: Trace net problem
Reply #3 - Apr 27th, 2018 at 1:14am
 
Even though your TinyCad schematic looks correct, some components are not connected at all, hence VeeCAD lists them as "surplus to netlist". Other components might have some but not all pins unconnected too. Only connected pins trace in VeeCAD.

TinyCad can check for unconnected pins. In TinyCad, go "Special -> Check Design Rules", check only the "Design error" checkboxes and run the check.

To connect reliably in TinyCAD, you must use the grid. In TinyCad, go "Options -> Settings", and make sure that "Snap to grid" and "Fine grid spacing" are checked. The TinyCad libraries supplied with VeeCAD have pins on the grid. When you create your own components in the TinyCad component editor you must also place pins on the grid.

Once your schematic is error free, import into VeeCAD and see if Trace Net works for you. If still no luck, email me your VeeCAD file, and I will help solve the mystery.
Back to top
« Last Edit: Apr 28th, 2018 at 1:14pm by Roger Lascelles »  

Roger
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print